Service levels for app-native challenge transactions in the 3DS ACS (US region) have returned to normal. We are continuing to monitor closely but no further issues have been observed.
Posted May 22, 2025 - 15:38 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2025 - 12:20 UTC
Monitoring
We've made changes to our HSM config to stabilize the app-native transactions. We're currently monitoring the transactions to see if failures continue.
Posted May 21, 2025 - 13:41 UTC
Identified
The issue has been identified, and it seems to involve JWS signing keys in the ACS admin.
Posted May 21, 2025 - 11:50 UTC
Investigating
Earlier, we reported and resolved an issue causing app-native transaction failures for 3DS ACS in the US region. However, the problem has since recurred intermittently.
As of approximately 04:04 UTC, we observed continued transaction timeouts. Due to low traffic volumes at the time, initial indications suggested the issue was fully resolved, but further occurrences have confirmed it is ongoing.
Our teams are actively investigating and working to identify the root cause. We will provide updates as more information becomes available.
Posted May 21, 2025 - 11:42 UTC
This incident affected: Omni-channel Authentication (Customer Authentication - US) and 3DS & Payment Authentication (3DS ACS - US).