Database Issues affecting ACS operations

Incident Report for Entersekt

Postmortem

The outage was caused by a partial DB cluster saturation. We have identified the exact cause, and are modifying the procedure to prevent this from happening in the future.

Posted May 21, 2025 - 12:38 UTC

Resolved

The issue has been fixed.
Posted May 21, 2025 - 11:04 UTC

Monitoring

We are currently monitoring the transactions to see if it will stabilize.
Posted May 21, 2025 - 11:02 UTC

Identified

The issue has been identified: it was due to a maintenance work that caused the issue.

The maintenance work was stopped, and the problem went away.
Posted May 21, 2025 - 11:01 UTC

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 10:49 UTC

Investigating

We are currently experiencing database issues, which are affecting transactions in production.

We are working to resolve this issue, and will provide more details shortly.
Posted May 21, 2025 - 10:49 UTC
This incident affected: 3DS & Payment Authentication (3DS ACS - Europe) and Omni-channel Authentication (Customer Authentication - Europe).